菜鸟调错——启动Tomcat报错“Unsupported major.minor version xxx ”

最近项目更新JDK,由之前的1.7更新到1.8。下载并安装好新的JDK以后,编译、启动Tomcat的时候,报错了,提示:“Unsupported major.minor version xxx ”。具体解决的过程就不在这详细说明了。跟大家分享一下解决方案吧。

 

首先,出现这个错误是因为编译的JDK版本,跟运行时所用的JDK版本不一致所导致的。所以解决方案就是统一JDK的版本。具体如下:

1,设置Maven编译的版本,maven-compiler-plugin  jdk版本

            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>3.1</version>
                <configuration>
                    <source>1.8</source>
                    <target>1.8</target>
                    <encoding>UTF-8</encoding>
                    <compilerVersion>1.8</compilerVersion>
                </configuration>
            </plugin>

 

 

 

2,Eclipse全局Compiler compliance level

 

3,项目的Compiler compliance level

 

,4,Tomcat所用的jdk

 

 

严格来讲,只需要设置第一、第四个的JDK应该就可以解决问题,但是为了避免以后再出现,需要把第二、第三步也设置一下。

 

最后附上jDK版本对应的数字代码:

JDK 8 = 52,
JDK 7 = 51,
JDK 6.0 = 50,
JDK 5.0 = 49,
JDK 1.4 = 48,
JDK 1.3 = 47,
JDK 1.2 = 46,
JDK 1.1 = 45

 

 

刘水镜 CSDN认证博客专家 Spring Boot 架构 Java
【欢迎阅读我的最新专栏——《SpringBoot趣味私房课》https://www.imooc.com/read/75】【欢迎加入「开发者」技术交流群:168965372】【群链接:https://jq.qq.com/?_wv=1027&k=Inxd5Aa9】
已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 猿与汪的秘密 设计师:上身试试 返回首页